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Linked data tables allow you to connect one or more tables by information common to both. For example, you can
have one table of schools that contains all the categorical information about each school (location, size, level, urban v
rural, etc.) and a separate table of all teachers. To disaggregate teachers by the information about their schools (e.g.
# teachers in urban settings) you can link teachers to their schools without having to repeat a school's categorical
information for each teacher. Another term for this method of organizing information is relational data; the data is
related by a shared column. This page includes:

= How to define the Lookup Key, the shared column between tables
= How to Link Tables
= How to Add Data to linked tables

Lookup Key

First, make sure you have enabled the Linked Data Tables feature under Administration > Settings.

Example Organization

DevResults

Quick search... Q

Program Info Tools Administration Bookmarks

Home * Administration * Settings

Pri Settings
Logo English (UK) (British English)
For best results,
upload a png file Burmese (Burmese)

with a white or N
transparent I Upload logo Nederlands (Dutch)
background with YkpaiHceka (Ukrainian)

solid colors ... or drag and drop your file here

Features

You may turn off features that won't be needed by this program.
w . -
Document Storage ] Awarding Organizations |
Calendar
Checklists

Storage i DevResults
Provider Change Data Table Row Locking
Discussions
5 Document Library
Fiscal Year Form Library
Starts on October 1 of the previous calendar year Il

Linked Data Tables
Partner Dashboards

Performance

Photo Library

O surveyCTO Integration

Financial

Finance

To link tables, find the Lookup Key section in the Design tab of the table that contains the information you'd like to
like to pull into a different table. In our example, we want to add a Lookup Key to the Schools table so that we can
pull information about schools into our Teachers table.
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Column Type
| school ID Unigue ID
* scrootacton Geograpy: Locton
* Urban/Rural Disaggregation: Urban vs Rural This data table is not linked to any indicators.
% # dassroom Number: Whole 4 Add an indicator mapping
% school's partner NGO Activity

Lookup Key

Configure how rows from this table are shown in other tables.

Lookup key is required for this table to be referenced by other tables and must produce a unique value for each row in the table. Learn more

Enter the lookup key with column names in [brackets]

Permissions

Define what access partner users have to this table

8 No Access v

The Lookup Key serves two functions:

1. It produces a unique value for each row in a table that is used to link each row of a table to a row in another
table.

2. You can configure it to display information in a different table in a specific format.

To begin entering a Lookup Key, click in the text box and add a bracket. This will give you a dropdown menu of all
columns in your table. You can continue typing the name of the column or click on the column name to select it.

In the following example, we've created a unique Lookup Key by combining School ID and School Location. The
Lookup Key in this case is [School ID][School Location].
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Table Name  schools

Calumn Type

| school ID Unigue ID

* scrottacaton egrapyLocton
* | Urban/Rural Disaggregation: Urban vs Rural This data table Is not linked to any indicators.

% #dassroom Number: Whole + Add an Indicator mapping

$ School's partner NGO Activity

Lookup Key

Configure how rows from this table are shown in other tables.

Lookup key is required for this table to be referenced by other tables and must produce a unique value for each row in the table. Learn
more

Enter the lockup key with column names in [brackets] T

Permissions

Define what access partner users have to this table

If we were to link a row in this table with a row in a different table, a row where School ID is "123" and School
Location is "Washington DC" will now display as "123Washington DC".



To configure the Lookup Key in a specific format, users can add spaces and special characters between column
names. In the example below, we've made the Lookup Key and display more readable by adding a comma between
the School ID and School Location.
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Table Name  Schools

Column Type
| School ID Unique ID
*  Urban/Rural Disaggregation: Urban vs Rural This data table is not linked to any indicators,
% # dassroom Number: Whole = Add an indicator mapping
3+ schools partner NGO Activity

Lookup Key

Configure how rows from this table are shown in other tables.

Lookup key is required for this table to be referenced by other tables and must produce a unique value for each row in the table. Learn
more

[School ID], [School Location]

Permissions

Define what access partner users have to this table
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NOTE: If a Lookup Key cannot produce a unique values for all rows, you will receive an error message asking you
to add additional columns to the Key until each value is unique. Similarly, if data is being added to the table that
will render the Lookup Key not unique, you will be prompted to fix the duplicate data.

Linking Existing Data Tables

To link a data table to another, navigate to the data table you want to link. In this example, we'll be connecting the
School table to a table of Teacher Records.
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Schools / 128  School ID, School Location, Urban/Rural, # classroom, School's partner NGO
Teacher Records 0 Sex, # years as teacher, # years post-training, Assessment date, Start date of school year, Country
Teachers 987 Teacher|D, Classroom ID, Sex, # years as teacher, # years post-training, Assessment Score, Assessment date, Start date of school year, Cohort, Countr
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Teachers post-training Teacher ID, Duration

Training Table 6,650 Date, Last Day of RP, Activity. Location, Trainee ID, Sex. Age, Training Topic, Training Type, Initial Test Score, Final Test Score, Points Improved, Commel

Click on the Design tab.
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No data has been added to this data table. Add a row or import data to get started.

i Delete this data table + Done

This table already has several columns added, including the # years as a teacher, # years post-training, when the
school year started, and where they are based. To pull in information about their school from the Schools table, click
on (+) Add new column.
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Table Name  Teacher Records

column Type

* sex Disaggregation: Sex

* #yeorsas o osaggregtor:ouraton
¥ #years post-training Other Text This data table is not linked to any indicators.

1 Assessment date Date < Add an indicator mapping

| startdate of school year Date

1 country Geography: Guinea

Lookup Key

Configure how rows from this table are shown in other tables.

Lookup key is required for this table to be referenced by other tables and must produce a unique value for each rowin the table. Learn
more

Enter the lookup key with column names in [brackets]

Permissions

Define what access partner users have to this table

In the popup, you can specify what the column should be called. Click on the dropdown for Type and select Table.
You can now click on the Table dropdown and select which data table you would like to connect.
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Disaggregation

| # years post-training Other Te o any indicators.
1 Assessment date Date + Add an indicator mapping
| Start date of school year Date
* | country Geography: Guinea

Lookup Key

Configure how rows from this table are shown in other tables.
Lookup key is required for this table to be referenced by other tables and must produce a unique value for each row i the table. Learn
more

Enter the lookup key with column names in [brackets]

Permissions

Define what access partner users have to this table

Click on (+) Add Column.
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+ #years as teacher X Disaggregation: Duration LiNKed lnaicators

+  #years post-training Other Text This data table is not linked to any indicators.
T | Assessment date Date | = Add an indicator mapping |

 start date of school year Date
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Lookup Key

Configure how rows from this table are shown in other tables.

Lookup key is required for this table to be referenced by other tables and must produce a unique value for each rowin the table. Learn
more

Enter the lookup key with column names in [brackets]

Permissions

Define what access partner users have to this table

Note: Tables will not show up in the dropdown if a Lookup Key is not specified for that table. Tables will also
now show up in the dropdown if you have not enabled the Linked Data Tables feature under
Administration > Settings .

Once you've added the column, DevResults will display all columns available from related tables, including those
currently available and ones that are pending.
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Column Type

T sex Disaggregation: Sex
T #years as teacher Disaggregation: Duration Linked Indicators
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% Assessment date Date < Add an indicator mapping
| Startdate of school year Date
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Current Pending Changes

Adding: School: School's partner NGO

Lookup Key

Configure how rows from this table are shown in other tables.

Lookup key is required for this table to be referenced by other tables and must produce a unique value for each row in the table. Learn
more

I A\ Lookup key cannot be changed while there are unsaved column changes
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Once you've reviewed the pending changes, click on Save changes to link the tables.

Add data




You can now navigate to the Data tab to begin adding data, including information stored in the "Schools" table.

Click on (+) Add new row.
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No data has been added to this data table. Add a row or import data to get started.

a table + Done

You'll notice that adding information to the new row remains the same.

When adding information from the "Schools" table (column: School) to a row, you can click on the dropdown and
select the School ID and Location you want to include in that specific column.
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Click Save to add the new row.

If you want to display the School ID and Location separately, you can do so by clicking on the gear icon on the top
right corner of the table.
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Columns

Search Columns...

@ KeyValue

¥ Sex

@ #years as teacher

@ #years post-training
@ Assessment date

@ Start date of school year
@ Country

\ @ School

[ school: School ID

[ school: School Location
O School: Urban/Rural

() School: # classroom

In the list of columns below, you can choose to display any columns in the table you linked to this one. In our
example, we can choose to display School: Urban/Rural, School: # classrooms, etc. If we want to remove the Lookup
Key from the table, we can uncheck the box next to it. In our example, that would be the School column.

TIP: If you are creating a new data table by uploading an example that links to another table, values in one of
the columns in the data table should match the generated Lookup Key in the second data table. In the example
above, we would have added School as a column, with all values in the column formatted as

School ID, School Location

Once you've created a linked table, you can start populating indicators with this data.

Didn't answer your question? Please email us athelp@devresults.com.
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